Your site is running on WordPress 3.0.5. Travel Blogger Theme requires at least WordPress 3.6. Please consider upgrading WordPress, it's safer, faster and carries more features.